Insomnia cure: One dragon. Two dragon. Three dragon, the princess was counting. She had trouble falling asleep, and she got bored of counting lambs when she was nine.
However, just counting dragons was boring as well, so she entertained herself at best she could. Tonight she imagined that all dragons were here to steal her, and she was fighting them off. Every k-th dragon got punched in the face with a frying pan. Every l-th dragon got his tail shut into the balcony door. Every m-th dragon got his paws trampled with sharp heels. Finally, she threatened every n-th dragon to call her mom, and he withdrew in panic.
Write a program to find how many imaginary dragons suffered moral or physical damage tonight, if the princess counted a total of d dragons?
Input and Output Format:
Input data contains integer numbers k, l, m, n and d, each number in a separate line (1 ≤ k, l, m, n ≤ 10, 1 ≤ d ≤ 105).
The output displays the number of damaged dragons.
Sample Input 1:
1
2
3
4
12
Sample Output 1:
12
Sample Input 2:
2
3
4
5
24
Sample Output 2:
17
Solution
import java.util.*;
class Main{
public static void main(String[] args) {
Scanner sc = new Scanner(System.in);
int a = sc.nextInt();
int b = sc.nextInt();
int c = sc.nextInt();
int d = sc.nextInt();
int e = sc.nextInt();
int count = 0;
for(int i = 1; i <= e; i++){
if(i % a == 0 || i % b == 0 || i % c == 0 || i % d == 0){
count++;
}
}
//sauravhathi
System.out.println(count);
}
}
a = int(input())
b = int(input())
c = int(input())
d = int(input())
e = int(input())
count = 0
for i in range(1, e+1):
if i % a == 0 or i % b == 0 or i % c == 0 or i % d == 0:
count += 1
#sauravhathi
print(count)
#include<iostream>
using namespace std;
int main()
{
int k,l,m,n,i,d,c=0;
cin>>k>>l>>m>>n>>d;
for(i=1;i<=d;i++)
{
if(i%k==0||i%l==0||i%m==0||i%n==0)
{
c++;
}
}
cout<<c;
//sauravhathi
}
Happy Learning – If you require any further information, feel free to contact me.